Contact Center Dashboard Delays
Incident Report for Broadvoice
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 17:53 PDT
Update
Our teams are continuing to work for a resolution to this issue.
Posted Jun 14, 2022 - 07:54 PDT
Update
Our teams are continuing to work for a resolution to this issue.
Posted Jun 13, 2022 - 19:08 PDT
Investigating
We are noticing delays with our contact center dashboard. Our teams are currently investigating and we expect a resolution within the next 4 hours.
Posted Jun 13, 2022 - 13:54 PDT
This incident affected: North America :: b-hive (Contact Center).