Voicemail and Fax Delivery Delays
Incident Report for Broadvoice
Resolved
The incident has been resolved as of 12 PM PST.
Posted Sep 26, 2019 - 12:41 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2019 - 10:58 PDT
Identified
Customers may experience delays in receiving voicemails, faxes and viewing CDRs in the portal. Engineers are working to resolve the issue.
Posted Sep 26, 2019 - 10:45 PDT
This incident affected: North America :: b-hive (Portal, Virtual Fax, Voicemail).