Intermittent Issues loading Portal
Incident Report for Broadvoice
Resolved
This incident has been resolved.
Posted Sep 06, 2019 - 10:58 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2019 - 10:43 PDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2019 - 10:28 PDT
This incident affected: North America :: b-hive (Portal).