P3 - Inbound Call Routing Issue

Incident Report for Broadvoice

Resolved

This was posted in error and there are no known issues at the current time.
Posted Jul 13, 2026 - 17:05 PDT

Investigating

We are currently investigating this issue.
Posted Jul 13, 2026 - 16:47 PDT
This incident affected: North America :: GoContact (Voice Inbound).