Post dial delay on Bhive
Incident Report for Broadvoice
Resolved
As of 2:35 PM PST today we have resolved the issue with PDD in our network.
Posted Dec 17, 2024 - 16:18 PST
Investigating
We are currently investigating reports of long post dial delay from Bhive..
Posted Dec 17, 2024 - 13:15 PST
This incident affected: North America :: b-hive (Call Processing).