Performance Degradation Due to Upstream Internet Providers
Incident Report for Broadvoice
Resolved
CenturyLink has repaired the issue within their network that caused widespread degradation across the Internet as a whole today including network carriers and software as a service providers like Broadvoice.

Our network engineers worked with the upstream carrier and confirmed resolution.
Posted Apr 21, 2020 - 16:25 PDT
Monitoring
CenturyLink is working to repair the fiber cuts within their network that caused widespread degradation across the Internet as a whole today including network carriers and software as a service providers like Broadvoice.

Our upstream Internet providers have worked to route around the issue wherever possible and similarly many local service providers that provide Internet connectivity to end users have made similar changes. As a result, are not receiving new reports of issues and we are seeing performance improvements for most customers.

If you continue to see an issue, we recommend reporting the issue to your Internet provider as well to ensure they have taken measures to route around the issues as well. Broadvoice customers working from home may also want to try to reboot their service providers modem or router as this can often reset connectivity to the Internet.
Our network engineers will continue to closely monitor and work with the upstream carrier until they have full resolution. We will provide further updates as we receive more information.

More information is available on Down Detector: https://downdetector.com/status/centurylink/
Posted Apr 21, 2020 - 12:43 PDT
Identified
The issue has been isolated to an upstream Internet carrier (CenturyLink/Level3) and caused by fiber cuts within their network. Broadvoice has confirmed that our network is operating normally and that the issue is a result of the upstream carrier. We are working closely with the upstream carrier and where possible have routed around the issue. These reports are consistent with other carriers who are also experiencing similar issues.

Though we are no longer receiving new reports of voice degradation issues, we are continuing to work closely with our upstream carrier. We will be updating this status notification within an hour.

More information is available on Down Detector: https://downdetector.com/status/centurylink/
Posted Apr 21, 2020 - 10:46 PDT
Investigating
We are currently investigating reports of voice degradation across our voice services. Currently, there seems to be an Internet issue upstream from the Broadvoice network that is causing performance voice quality issues for many customers. We have tickets open with our upstream Internet providers. We will be updating this status notification in one hour.
Posted Apr 21, 2020 - 09:47 PDT
This incident affected: North America :: b-hive (Call Quality) and North America :: Cloud PBX (Call Quality).