AWS outage update

Incident Report for Broadvoice

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:37 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 18:53 PDT

Identified

We are currently monitoring a widespread AWS outage that may be impacting the performance of some of our services. While our systems remain operational, customers may experience intermittent delays or degraded performance in certain areas.
Our engineering team is actively working to mitigate any impact and is closely tracking AWS’s recovery efforts. We will provide updates as more information becomes available.
We appreciate your patience and understanding.
Posted Oct 20, 2025 - 12:58 PDT
This incident affected: North America :: b-hive (Call Processing, Call Quality, Call Recording, Communicator, Contact Center, Device Provisioning, Device Registration, Edge SD-WAN, Mobile iPhone & Android App, Notifications, Portal, SIP Trunking, SMS, Website, Virtual Fax, Voicemail).